const regex = /([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+/simg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z0-9]+[.\\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+', 'simg')
const str = `<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \\rCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\rCOOKIES@lol.RU\\r.\\r\\n
ОМ ПО ЭЛ. ПОЧТЕ: \\nCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\sCOOKIES@lol.RU\\r.\\r\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}