// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sim)([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+").unwrap();
let string = "<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \\rCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\rCOOKIES@lol.RU\\r.\\r\\n
ОМ ПО ЭЛ. ПОЧТЕ: \\nCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\sCOOKIES@lol.RU\\r.\\r\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}