package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sim)([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+`)
var str = `<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \rCO-O.KI-ES@lol.RU\r.\r\nОМ ПО ЭЛ. ПОЧТЕ: \rCOOKIES@lol.RU\r.\r\n
ОМ ПО ЭЛ. ПОЧТЕ: \nCO-O.KI-ES@lol.RU\r.\r\nОМ ПО ЭЛ. ПОЧТЕ: \sCOOKIES@lol.RU\r.\r\n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}