re = /([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+/im
str = '<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \\rCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\rCOOKIES@lol.RU\\r.\\r\\n
ОМ ПО ЭЛ. ПО ЧТЕ: \\nCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\sCOOKIES@lol.RU\\r.\\r\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end