import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z0-9]+[.\\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+";
final String string = "<i><b>YudV@lol.ru</b></i></a>\n"
+ "ОМ ПО ЭЛ. ПОЧТЕ: \\rCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\rCOOKIES@lol.RU\\r.\\r\\n\n\n"
+ "ОМ ПО ЭЛ. ПОЧТЕ: \\nCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\sCOOKIES@lol.RU\\r.\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}