import Foundation
let pattern = #"([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \rCO-O.KI-ES@lol.RU\r.\r\nОМ ПО ЭЛ. ПОЧТЕ: \rCOOKIES@lol.RU\r.\r\n
ОМ ПО ЭЛ. ПОЧТЕ: \nCO-O.KI-ES@lol.RU\r.\r\nОМ ПО ЭЛ. ПОЧТЕ: \sCOOKIES@lol.RU\r.\r\n
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)