# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\w ]*)-[\w ]{6,}$/\g<1>/gm;t' <<< "blaablaablaablaa - blaablaa-12n
blaablaablaa-n3n
blaablaa - blaablaa-4nn5
blaablaablaablaa-nn0
blaablaablaa
blaablaablaablaa - blaablaa-12n123
blaablaablaablaa - blaablaa-12n12
blaablaablaablaa-nn0123"