# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\w ]*)-[\w ]{6,}$"
test_str = ("blaablaablaablaa - blaablaa-12n\n"
"blaablaablaa-n3n\n"
"blaablaa - blaablaa-4nn5\n"
"blaablaablaablaa-nn0\n"
"blaablaablaa\n"
"blaablaablaablaa - blaablaa-12n123\n"
"blaablaablaablaa - blaablaa-12n12\n"
"blaablaablaablaa-nn0123")
subst = "\\g<1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.