// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w ]*)-[\w ]{6,}$").unwrap();
let string = "blaablaablaablaa - blaablaa-12n
blaablaablaa-n3n
blaablaa - blaablaa-4nn5
blaablaablaablaa-nn0
blaablaablaa
blaablaablaablaa - blaablaa-12n123
blaablaablaablaa - blaablaa-12n12
blaablaablaablaa-nn0123";
let substitution = "\\g<1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}