$re = '/^([\w ]*)-[\w ]{6,}$/m';
$str = 'blaablaablaablaa - blaablaa-12n
blaablaablaa-n3n
blaablaa - blaablaa-4nn5
blaablaablaablaa-nn0
blaablaablaa
blaablaablaablaa - blaablaa-12n123
blaablaablaablaa - blaablaa-12n12
blaablaablaablaa-nn0123';
$subst = "\g<1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;