use strict;
my $str = 'blaablaablaablaa - blaablaa-12n
blaablaablaa-n3n
blaablaa - blaablaa-4nn5
blaablaablaablaa-nn0
blaablaablaa
blaablaablaablaa - blaablaa-12n123
blaablaablaablaa - blaablaa-12n12
blaablaablaablaa-nn0123';
my $regex = qr/^([\w ]*)-[\w ]{6,}$/mp;
my $subst = '\\g<1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";