import Foundation
let pattern = #"^([\w ]*)-[\w ]{6,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
blaablaablaablaa - blaablaa-12n
blaablaablaa-n3n
blaablaa - blaablaa-4nn5
blaablaablaablaa-nn0
blaablaablaa
blaablaablaablaa - blaablaa-12n123
blaablaablaablaa - blaablaa-12n12
blaablaablaablaa-nn0123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)