#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([\w ]*)-[\w ]{6,}$"
Local $sString = "blaablaablaablaa - blaablaa-12n" & @CRLF & _
"blaablaablaa-n3n" & @CRLF & _
"blaablaa - blaablaa-4nn5" & @CRLF & _
"blaablaablaablaa-nn0" & @CRLF & _
"blaablaablaa" & @CRLF & _
"blaablaablaablaa - blaablaa-12n123" & @CRLF & _
"blaablaablaablaa - blaablaa-12n12" & @CRLF & _
"blaablaablaablaa-nn0123"
Local $sSubst = "\g<1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)