using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w ]*)-[\w ]{6,}$";
string substitution = @"\g<1>";
string input = @"blaablaablaablaa - blaablaa-12n
blaablaablaa-n3n
blaablaa - blaablaa-4nn5
blaablaablaablaa-nn0
blaablaablaa
blaablaablaablaa - blaablaa-12n123
blaablaablaablaa - blaablaa-12n12
blaablaablaablaa-nn0123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}