# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/print\s+\"(.+)\"/ print("\1")/gm;t' <<< "print \"Anything goes here\"
print \"Anything\"
print \"Something goes here\" "