#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^text/\p{Cyrillic}(?: ?\p{Cyrillic})*$"
Local $sString = "text/выаваываыва" & @CRLF & _
"text/выава ываыва" & @CRLF & _
"text/ываыва%D0%B1" & @CRLF & _
"text/выава ываыва" & @CRLF & _
"text/ выаваываыва" & @CRLF & _
"text/выаваываыва " & @CRLF & _
"text/1выаваываыва" & @CRLF & _
"text/выаваываыва2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")