$re = '@^text/\p{Cyrillic}(?: ?\p{Cyrillic})*$@m';
$str = 'text/выаваываыва
text/выава ываыва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);