using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^text/\p{Cyrillic}(?: ?\p{Cyrillic})*$";
string input = @"text/выаваываыва
text/выава ываыва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}