// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^text/\p{Cyrillic}(?: ?\p{Cyrillic})*$").unwrap();
let string = "text/выаваываыва
text/выава ываы ва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}