use strict;
my $str = 'text/выаваываыва
text/выава ываыва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2';
my $regex = qr@^text/\p{Cyrillic}(?: ?\p{Cyrillic})*$@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}