const regex = new RegExp('^text/\\p{Cyrillic}(?: ?\\p{Cyrillic})*$', 'gm')
const str = `text/выаваываыва
text/выава ываыва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}