package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^text/\p{Cyrillic}(?: ?\p{Cyrillic})*$`)
var str = `text/выаваываыва
text/выава ываыва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}