re = /^text\/\p{Cyrillic}(?: ?\p{Cyrillic})*$/m
str = 'text/выаваываыва
text/выава ываыва
text/ываыва%D0%B1
text/выава ываыва
text/ выаваываыва
text/выаваываыва
text/1выаваываыва
text/выаваываыва2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end