# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^:]*?\K |\G[^:]*?\K /\\ /gs;t' <<< "NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7
Note there is a space after each \K"