using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^:]*?\K |\G[^:]*?\K ";
string substitution = @"\\ ";
string input = @"NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7
Note there is a space after each \K";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}