import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^:]*?\\K |\\G[^:]*?\\K ";
final String string = "NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7\n\n"
+ "Note there is a space after each \\K";
final String subst = "\\\\ ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}