re = /^[^:]*?\K |\G[^:]*?\K /
str = 'NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7
Note there is a space after each \\K'
subst = '\\\\ '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result