$re = '/^[^:]*?\K |\G[^:]*?\K /s';
$str = 'NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7
Note there is a space after each \\K';
$subst = "\\ ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;