const regex = /^[^:]*?\K |\G[^:]*?\K /gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^:]*?\\K |\\G[^:]*?\\K ', 'gs')
const str = `NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7
Note there is a space after each \\K`;
const subst = `\\ `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);