import Foundation
let pattern = #"^[^:]*?\K |\G[^:]*?\K "#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.7
Note there is a space after each \K
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\ "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)