# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\p{Han}+)(?:\P{Han}.*\1)?$/$1 $2/gm;t' <<< "测试1003##$%#测试
测试1003##$%#测
测试
"