use strict;
my $str = '测试1003##$%#测试
测试1003##$%#测
测试
';
my $regex = qr/^(\p{Han}+)(?:\P{Han}.*\1)?$/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";