import re
regex = re.compile(r"^(\p{Han}+)(?:\P{Han}.*\1)?$", flags=re.MULTILINE)
test_str = ("测试1003##$%#测试\n"
"测试1003##$%#测\n"
"测试\n")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)