$re = '/^(\p{Han}+)(?:\P{Han}.*\1)?$/m';
$str = '测试1003##$%#测试
测试1003##$%#测
测试
';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;