#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\p{Han}+)(?:\P{Han}.*\1)?$"
Local $sString = "测试1003##$%#测试" & @CRLF & _
"测试1003##$%#测" & @CRLF & _
"测试" & @CRLF & _
""
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)