import Foundation
let pattern = #"^(\p{Han}+)(?:\P{Han}.*\1)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
测试1003##$%#测试
测试1003##$%#测
测试
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)