using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\p{Han}+)(?:\P{Han}.*\1)?$";
string substitution = @"$1 $2";
string input = @"测试1003##$%#测试
测试1003##$%#测
测试
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}