using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([^,\s]+)(?:,|$)";
string substitution = @"self.$1 = $1\n";
string input = @"toto, titi, tata";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}