package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([^,\s]+)(?:,|$)`)
var str = `toto, titi, tata`
var substitution = "self.$1 = $1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}