$re = '/\s*([^,\s]+)(?:,|$)/m';
$str = 'toto, titi, tata';
$subst = "self.$1 = $1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;