const regex = /\s*([^,\s]+)(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([^,\\s]+)(?:,|$)', 'gm')
const str = `toto, titi, tata`;
const subst = `self.$1 = $1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);