#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?!\.) )\b[a-z]\w+"
Local $sString = "var touchHandler = function(e)..." & @CRLF & _
"var touch = event.hasOwnProperty..." & @CRLF & _
" event.changedTouches..." & @CRLF & _
" event.originalEvent.changedTouches..." & @CRLF & _
"" & @CRLF & _
" var simulatedEvent = document.createEvent(..." & @CRLF & _
" simulatedEvent.initMouseEvent({ touchend: "mouseup"})" & @CRLF & _
"" & @CRLF & _
" touch.target.dispatchEvent(simulatedEvent);" & @CRLF & _
" event.preventDefault();" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")