re = /((?!\.) )\b[a-z]\w+/i
str = 'var touchHandler = function(e)...
var touch = event.hasOwnProperty...
event.changedTouches...
event.originalEvent.changedTouches...
var simulatedEvent = document.createEvent(...
simulatedEvent.initMouseEvent({ touchend: "mouseup"})
touch.target.dispatchEvent(simulatedEvent);
event.preventDefault();
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end