import Foundation
let pattern = #"((?!\.) )\b[a-z]\w+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
var touchHandler = function(e)...
var touch = event.hasOwnProperty...
event.changedTouches...
event.originalEvent.changedTouches...
var simulatedEvent = document.createEvent(...
simulatedEvent.initMouseEvent({ touchend: "mouseup"})
touch.target.dispatchEvent(simulatedEvent);
event.preventDefault();
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)