import re
regex = re.compile(r"((?!\.) )\b[a-z]\w+", flags=re.IGNORECASE)
test_str = ("var touchHandler = function(e)...\n"
"var touch = event.hasOwnProperty...\n"
" event.changedTouches...\n"
" event.originalEvent.changedTouches...\n\n"
" var simulatedEvent = document.createEvent(...\n"
" simulatedEvent.initMouseEvent({ touchend: \"mouseup\"})\n\n"
" touch.target.dispatchEvent(simulatedEvent);\n"
" event.preventDefault();\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")