import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?!\\.) )\\b[a-z]\\w+";
final String string = "var touchHandler = function(e)...\n"
+ "var touch = event.hasOwnProperty...\n"
+ " event.changedTouches...\n"
+ " event.originalEvent.changedTouches...\n\n"
+ " var simulatedEvent = document.createEvent(...\n"
+ " simulatedEvent.initMouseEvent({ touchend: \"mouseup\"})\n\n"
+ " touch.target.dispatchEvent(simulatedEvent);\n"
+ " event.preventDefault();\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}