package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\.\.\/.*temp`)
var str = `<p><img class="m-4" src="../../../img/page/temp/dd2b0a2c5925e4f55da1992456eb9ef8.webp" alt="" width="295" height="360"></p>`
var substitution = "url_id_page_"
fmt.Println(re.ReplaceAllString(str, substitution))
}