const regex = /\.\.\/.*temp/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.\\.\\\/.*temp', 'gmi')
const str = `<p><img class="m-4" src="../../../img/page/temp/dd2b0a2c5925e4f55da1992456eb9ef8.webp" alt="" width="295" height="360"></p>`;
const subst = `url_id_page_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);