import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.\\.\\/.*temp";
final String string = "<p><img class=\"m-4\" src=\"../../../img/page/temp/dd2b0a2c5925e4f55da1992456eb9ef8.webp\" alt=\"\" width=\"295\" height=\"360\"></p>";
final String subst = "url_id_page_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}