re = /\.\.\/.*temp/mi
str = '<p><img class="m-4" src="../../../img/page/temp/dd2b0a2c5925e4f55da1992456eb9ef8.webp" alt="" width="295" height="360"></p>'
subst = 'url_id_page_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result